Top posting users this month
JohnW
 
adespin
 
barker
 
andrewp
 
3hundredspartans
 
Duckrider
 
Dave Weller
 

Top posting users this week
JohnW
 
3hundredspartans
 
andrewp
 

Who is online?
In total there are 2 users online :: 0 Registered, 0 Hidden and 2 Guests

None

[ View the whole list ]


Most users ever online was 29 on Tue 30 May - 4:54
Latest topics
» Tidy early T80 (A249HBE)
Wed 21 Feb - 5:29 by andrewp

» Hello from Cheshire
Tue 20 Feb - 9:40 by 3hundredspartans

» T80 CDI (new old stock)
Mon 19 Feb - 7:56 by JohnW

» Nice Mate !!
Sat 17 Feb - 9:41 by JohnW

» Nicer Mate !!
Thu 8 Feb - 10:11 by adespin

» T80 G401WLL London only 700 miles
Wed 7 Feb - 2:55 by adespin

» Grey T80 C947FMC Midhurst
Tue 6 Feb - 6:11 by JohnW

» l plate on my top box
Sun 4 Feb - 20:08 by barker

» ACF-50 and inner tubes.
Sun 4 Feb - 2:32 by andrewp


Clutch slipping ??

Go down

Clutch slipping ??

Post  pikey dave on Sun 15 Nov - 6:35

Hi all only just joined this site having only one problem with my T80 ,it seams to be slipping when trying to kick start . I was told its the clutch so I have put in new friction plates .It rides well and does not slip up hill while riding ,but still wont start ,well after many kicks . Was told by a Honda man that on a C90 the 4 springs can cause this ,??? any ideas and where would I get these springs . PS I have done the clutch adjuster .... thanks Dave Embarassed

pikey dave

Posts : 1
Join date : 2015-11-14

View user profile

Back to top Go down

Re: Clutch slipping ??

Post  JohnW on Sun 15 Nov - 7:20

pikey dave wrote:Hi all only just joined this site having only one problem with my T80 ,it seams to be slipping when trying to kick start . I was told its the clutch so I have put in new friction plates .It rides well and does not slip up hill while riding ,but still wont start ,well after many kicks . Was told by a Honda man that on a C90 the 4 springs can cause this ,??? any ideas and where would I get these springs . PS I have done the clutch adjuster .... thanks Dave Embarassed

Dont think its would be springs, maybe too much oil, suggest you fit new clutch plates, plenty on eBay
http://www.ebay.co.uk/sch/i.html?_from=R40&_trksid=p2050890.m570.l1313.TR0.TRC0.H0.XYamaha+T80+clutch+plates.TRS0&_nkw=Yamaha+T80+clutch+plates&_sacat=0

JohnW

Posts : 1070
Join date : 2011-10-29

View user profile

Back to top Go down

clutch

Post  oldskoolpulsar on Mon 16 Nov - 8:13

i adjusted the screw on the gear side of the transmission and kick start functioned again.

I had no kick start at all, and was barely able to push start the machine, turns out the clutch was out of adjustment

oldskoolpulsar

Posts : 55
Join date : 2015-10-16

View user profile

Back to top Go down

Re: Clutch slipping ??

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum